Legacy Versions

Warning Icon

Primate Labs recommends using Geekbench 5 to benchmark your system.

Primate Labs provides legacy versions of Geekbench for use on systems that cannot run the latest version of Geekbench.

Note that you cannot compare Geekbench scores from different Geekbench versions. For example, you cannot compare Geekbench 4 scores to Geekbench 5 or Geekbench 3 scores.

Geekbench 4

macOS
Requires macOS 10.10.5 or later
Windows
Requires Windows 7 or later
Linux
Requires Ubuntu 14.04 LTS or later

Geekbench 3

macOS
Requires Mac OS X 10.6.8 or later
Windows
Requires Windows 7 or later
Linux
Requires Ubuntu 12.04 LTS or later

Geekbench 2

macOS
Requires Mac OS X 10.5.8 or later
Windows
Requires Windows XP SP3 or later
Linux
Requires Ubuntu 8.04 LTS or later